เรื่อง: สอบถามเรื่อง NAT Foritgate 100d
 
 4909

My Name: ae1983 ออฟไลน์
  • ดูรายละเอียด
28 พ.ย. 19, 10:07:02น.
ผมได้ public ip /29 มาชุดนึงครับ 1 ip เป็นของ provider 1 ip ใช้เป็น wan ของ firewall
ตอนนี้ที่ firewall มีการทำ nat ออกไปโดยใช้ไอพีเดียวกับ ip wan ก็ใช้ได้ปกติ
ปัญหาคือ เวลาผม nat โดยใช้ไอพีที่ไม่ใช่ ip wan ของ firewall มันจะปิงเจออยู่แปบนึงแล้วก็ timeout ครับ

My Name: creodacious ออฟไลน์
  • ดูรายละเอียด
ตอบกลับ #1 28 พ.ย. 19, 11:59:10น.
NAT IP ชุดที่ว่ายังอยู่ใน subnet /29 ใช่ไหมครับ
แล้วที่ว่า Ping เจอ คือ Ping จาก Client ที่ทำ NAT ด้วย IP ชุดใหม่ออกไปข้างนอกใช่ไหม
ขอดูการตั้งค่า Dynamic pool หน่อยครับ

My Name: ae1983 ออฟไลน์
  • ดูรายละเอียด
ตอบกลับ #2 28 พ.ย. 19, 14:50:58น.
ip อยู่ใน subnet เดียวกันครับ
ส่วน dynamic pool ผมไม่ได้ใส่อะไรครับ
https://www.img.in.th/image/4gsaIv

คือ fortigate ตัวอื่นใช้คนละที่กัน ก็ไม่เห็นต้องใส่ยังใช้ได้อ่าครับ
แก้ไขครั้งสุดท้าย: 28 พ.ย. 19, 17:10:51น. โดย ae1983

My Name: ae1983 ออฟไลน์
  • ดูรายละเอียด
ตอบกลับ #3 29 พ.ย. 19, 11:53:24น.
พอจะแนะนำบ้างได้ไหมครับว่าน่าจะติดที่อะไรได้บ้าง

My Name: creodacious ออฟไลน์
  • ดูรายละเอียด
ตอบกลับ #4 29 พ.ย. 19, 17:31:12น.
ความต้องการคือ
จะให้ Client ออก Internet ด้วย IP WAN อีกเบอร์ ใช่ไหมครับ

ถ้าใช่ ให้สร้าง IP Pools เลยครับ แล้วใส่เบอร์ IP WAN ที่ต้องการและเลือก Overload
จากนั้นเอาไปใส่ใน Policy เลยครับใน NAT >> Use Dynamic IP Pool
แก้ไขครั้งสุดท้าย: 29 พ.ย. 19, 17:38:39น. โดย creodacious

My Name: ae1983 ออฟไลน์
  • ดูรายละเอียด
ตอบกลับ #5 23 ม.ค. 20, 15:20:35น.
ความต้องการคือ
จะให้ Client ออก Internet ด้วย IP WAN อีกเบอร์ ใช่ไหมครับ

ถ้าใช่ ให้สร้าง IP Pools เลยครับ แล้วใส่เบอร์ IP WAN ที่ต้องการและเลือก Overload
จากนั้นเอาไปใส่ใน Policy เลยครับใน NAT >> Use Dynamic IP Pool
ขั้นตอนนี้ทำได้แล้วครับแต่ข้างนอกมันปิงไม่เห็นไอพีอ่าครับ ปิงขาในเจอนะครับ เช่น gw provider เป็น 147.50.50.161 ip firewall เป็น 147.50.50.162 ผมต้องการให้ server ภายใน ใช้ ip 147.50.50.165 ขาในเช่น 10.10.10.165 ครับ ปัญหาคือ ออกด้วยไอพี 147.50.50.165 ได้ แต่ปิงไม่เจอ
แก้ไขครั้งสุดท้าย: 23 ม.ค. 20, 15:36:20น. โดย ae1983

My Name: Touch ออฟไลน์
  • ดูรายละเอียด
ตอบกลับ #6 23 ม.ค. 20, 17:55:05น.
ที่ทำตอนนี้คือออกด้วย IP ที่ต้องการแล้วใช้งานอินเทอร์เน็ตได้ปกติแล้วหรือใช่ไหมครับ แต่แค่ Ping แล้วไม่เจอ IP

My Name: ae1983 ออฟไลน์
  • ดูรายละเอียด
ตอบกลับ #7 24 ม.ค. 20, 15:44:08น.
ที่ทำตอนนี้คือออกด้วย IP ที่ต้องการแล้วใช้งานอินเทอร์เน็ตได้ปกติแล้วหรือใช่ไหมครับ แต่แค่ Ping แล้วไม่เจอ IP
ใช่ครับผม ปกติที่เคยๆทำของ fortigate ที่อื่นมันจะทำบน Virtual IPs ได้เลย NAT ขาในกับขานอกก็เจอ แต่นี่ไม่เจอครับ มันน่าจะติดที่ตรงไหนได้บ้างครับ

My Name: ae1983 ออฟไลน์
  • ดูรายละเอียด
ตอบกลับ #8 27 ม.ค. 20, 14:37:14น.
ต้องการทำตรงนี้ครับถ้าเป็น IP 147.50.42.165 มันทำ Virtual IPs ไม่ได้ แต่ถ้าเป็น 147.50.42.162 ซึ่งเป็น IP ของ FW มันทำได้ครับ
https://www.picz.in.th/image/capture.RXGD50

My Name: Touch ออฟไลน์
  • ดูรายละเอียด
ตอบกลับ #9 27 ม.ค. 20, 14:49:51น.
ถ้า Mapped ถูกแล้วน่าจะต้องดูเรื่องของ Policy และ Services ที่เปิดให้ใช้งานครับว่ากำหนดไว้ถูกไหม